BETA

29th June 2022

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [29/06/22 05:45 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [29/06/22 06:15 PM]