BETA

2nd August 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/08/17 01:09 PM] with 'Major Outage'

Issue has been resolved at [02/08/17 01:10 PM]