BETA

19th August 2016

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [19/08/16 05:25 PM] with 'Partial Outage'

Issue has been resolved at [19/08/16 05:31 PM]