BETA

2nd August 2017

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [02/08/17 12:40 PM] with 'Partial Outage'

Issue has been resolved at [02/08/17 12:43 PM]