Exotel Status Board
Home
Dashboard
BETA
28th May 2022
Mumbai
Issue observed for 'Outgoing Calls' in Mumbai Region
Identified at [28/05/22 03:20 AM] with 'Major Outage'
Issue has been resolved at [28/05/22 03:25 AM]