BETA

19th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [19/08/16 12:53 AM] with 'Partial Outage'

Issue has been resolved at [19/08/16 12:55 AM]