Exotel Status Board
Home
Dashboard
BETA
7th May 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [07/05/22 03:30 AM] with 'Major Outage'
Issue has been resolved at [07/05/22 03:35 AM]