Exotel Status Board
Home
Dashboard
BETA
28th April 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [28/04/22 12:55 PM] with 'Major Outage'
Issue has been resolved at [28/04/22 01:00 PM]