Exotel Status Board
Home
Dashboard
BETA
9th April 2022
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [09/04/22 10:22 PM] with 'Major Outage'
Issue has been resolved at [09/04/22 10:25 PM]