Exotel Status Board
Home
Dashboard
BETA
9th April 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [09/04/22 01:17 AM] with 'Major Outage'
Issue has been resolved at [09/04/22 03:35 AM]