Exotel Status Board
Home
Dashboard
BETA
30th March 2022
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [30/03/22 05:25 PM] with 'Major Outage'
Issue has been resolved at [30/03/22 06:00 PM]