BETA

2nd August 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [02/08/17 10:00 AM] with 'Major Outage'

Issue has been resolved at [02/08/17 10:02 AM]