BETA

2nd August 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [02/08/17 10:00 AM] with 'Partial Outage'

Issue has been resolved at [02/08/17 10:02 AM]