BETA

18th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [18/08/16 12:10 AM] with 'Partial Outage'

Issue has been resolved at [18/08/16 12:12 AM]