Exotel Status Board
Home
Dashboard
BETA
29th March 2022
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [29/03/22 10:55 PM] with 'Major Outage'
Issue has been resolved at [29/03/22 11:00 PM]