Exotel Status Board
Home
Dashboard
BETA
28th March 2022
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [28/03/22 12:50 PM] with 'Major Outage'
Issue has been resolved at [28/03/22 01:00 PM]