BETA

28th March 2022

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [28/03/22 12:45 PM] with 'Major Outage'

Issue has been resolved at [28/03/22 12:50 PM]