BETA

2nd August 2017

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [02/08/17 09:54 AM] with 'Major Outage'

Issue has been resolved at [02/08/17 09:56 AM]