BETA

19th March 2022

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [19/03/22 09:40 AM] with 'Partial Outage'

Issue has been resolved at [19/03/22 02:05 PM]