Exotel Status Board
Home
Dashboard
BETA
13th March 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [13/03/22 02:20 AM] with 'Major Outage'
Issue has been resolved at [13/03/22 02:35 AM]