Exotel Status Board
Home
Dashboard
BETA
8th March 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [08/03/22 03:51 AM] with 'Major Outage'
Issue has been resolved at [08/03/22 04:00 AM]