Exotel Status Board
Home
Dashboard
BETA
27th February 2022
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [27/02/22 01:50 AM] with 'Major Outage'
Issue has been resolved at [27/02/22 02:00 AM]