BETA

2nd August 2017

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [02/08/17 09:37 AM] with 'Partial Outage'

Issue has been resolved at [02/08/17 11:04 AM]