Exotel Status Board
Home
Dashboard
BETA
23rd February 2022
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [23/02/22 12:35 PM] with 'Major Outage'
Issue has been resolved at [23/02/22 12:40 PM]