BETA

20th February 2022

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [20/02/22 11:50 AM] with 'Partial Outage'

Issue has been resolved at [20/02/22 12:04 PM]