BETA

19th February 2022

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [19/02/22 12:13 PM] with 'Partial Outage'

Issue has been resolved at [19/02/22 01:30 PM]