Exotel Status Board
Home
Dashboard
BETA
11th February 2022
Andhra Pradesh
Issue observed for 'Outgoing Calls' in Andhra Pradesh Region
Identified at [11/02/22 12:38 PM] with 'Major Outage'
Issue has been resolved at [11/02/22 12:40 PM]