BETA

31st July 2017

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [31/07/17 11:24 AM] with 'Major Outage'

Issue has been resolved at [31/07/17 11:25 AM]