BETA

17th March 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [17/03/19 06:03 PM] with 'Partial Outage'

Issue has been resolved at [17/03/19 06:06 PM]