Exotel Status Board
Home
Dashboard
BETA
12th December 2021
Andhra Pradesh
Issue observed for 'Outgoing Calls' in Andhra Pradesh Region
Identified at [12/12/21 01:25 PM] with 'Major Outage'
Issue has been resolved at [12/12/21 01:38 PM]