Exotel Status Board
Home
Dashboard
BETA
11th December 2021
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [11/12/21 06:23 PM] with 'Major Outage'
Issue has been resolved at [11/12/21 06:35 PM]