BETA

17th August 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [17/08/16 12:11 AM] with 'Partial Outage'

Issue has been resolved at [17/08/16 12:13 AM]