BETA

30th November 2021

Delhi Issue observed for 'Outgoing Calls' in Delhi Region
3 years ago

Identified at [30/11/21 09:25 PM] with 'Partial Outage'

Issue has been resolved at [30/11/21 09:30 PM]