Exotel Status Board
Home
Dashboard
BETA
28th November 2021
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [28/11/21 02:30 PM] with 'Major Outage'
Issue has been resolved at [28/11/21 03:02 PM]