Exotel Status Board
Home
Dashboard
BETA
28th November 2021
Delhi
Issue observed for 'Incoming Calls' in Delhi Region
Identified at [28/11/21 06:10 AM] with 'Major Outage'
Issue has been resolved at [28/11/21 06:15 AM]