BETA

17th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [17/03/19 02:31 PM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [17/03/19 02:33 PM]