Exotel Status Board
Home
Dashboard
BETA
27th November 2021
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [27/11/21 04:35 PM] with 'Major Outage'
Issue has been resolved at [27/11/21 04:40 PM]