Exotel Status Board
Home
Dashboard
BETA
26th November 2021
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [26/11/21 05:00 PM] with 'Major Outage'
Issue has been resolved at [26/11/21 05:12 PM]