Exotel Status Board
Home
Dashboard
BETA
26th November 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [26/11/21 01:33 PM] with 'Major Outage'
Issue has been resolved at [26/11/21 01:40 PM]