BETA

12th August 2016

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/08/16 12:09 AM] with 'Major Outage'

Issue has been resolved at [12/08/16 12:11 AM]