Exotel Status Board
Home
Dashboard
BETA
25th November 2021
Delhi
Issue observed for 'Outgoing Calls' in Delhi Region
Identified at [25/11/21 01:15 PM] with 'Major Outage'
Issue has been resolved at [25/11/21 01:20 PM]