Exotel Status Board
Home
Dashboard
BETA
12th November 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [12/11/21 11:50 PM] with 'Major Outage'
Issue has been resolved at [13/11/21 12:07 AM]