BETA

8th November 2021

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [08/11/21 12:30 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [13/11/21 12:40 AM]