BETA

17th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [17/03/19 01:42 PM] with 'Partial Outage'

Issue has been resolved at [17/03/19 01:43 PM]