Exotel Status Board
Home
Dashboard
BETA
19th October 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [19/10/21 09:05 AM] with 'Major Outage'
Issue has been resolved at [19/10/21 09:10 AM]