BETA

12th October 2021

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [12/10/21 02:40 PM] with 'Partial Outage'

Issue has been resolved at [12/10/21 02:55 PM]