Exotel Status Board
Home
Dashboard
BETA
10th October 2021
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
4 years ago
Identified at [10/10/21 03:30 PM] with 'Major Outage'
Issue has been resolved at [10/10/21 03:35 PM]