Exotel Status Board
Home
Dashboard
BETA
10th October 2021
Gujarat
Issue observed for 'Incoming Calls' in Gujarat Region
Identified at [10/10/21 02:30 AM] with 'Major Outage'
Issue has been resolved at [10/10/21 02:35 AM]