Exotel Status Board
Home
Dashboard
BETA
7th October 2021
Madhya Pradesh
Issue observed for 'Outgoing Calls' in Madhya Pradesh Region
Identified at [07/10/21 05:05 PM] with 'Major Outage'
Issue has been resolved at [07/10/21 05:18 PM]