Exotel Status Board
Home
Dashboard
BETA
6th October 2021
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [06/10/21 12:20 PM] with 'Major Outage'
Issue has been resolved at [06/10/21 12:25 PM]